华为mstp、vrrp、ospf、isis、bgp等综合一起排错

在这里插入图片描述

最终实现左边私网和右边私网全部ping通

SW1

vlan batch 12 34

stp region-configuration //mstp配置
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/10
port link-type access
port default vlan 12

interface GigabitEthernet0/0/11
port link-type access
port default vlan 12

SW2

vlan batch 12 34
stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/10
port link-type access
port default vlan 34

interface GigabitEthernet0/0/11
port link-type access
port default vlan 34

SW3

vlan batch 12 to 13 34

stp instance 12 root primary //设置为主根
stp instance 34 root secondary //设置为备根

stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface Vlanif12
ip address 192.168.12.3 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.12.254 //vrrp配置
vrrp vrid 1 priority 150

interface Vlanif13
ip address 10.0.13.3 255.255.255.0

interface Vlanif34
ip address 192.168.34.3 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.34.254

interface MEth0/0/1

interface GigabitEthernet0/0/1
port link-type access
port default vlan 13

interface GigabitEthernet0/0/2

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

ip route-static 0.0.0.0 0.0.0.0 10.0.13.1

SW4

vlan batch 12 14 34

stp instance 12 root secondary
stp instance 34 root primary

stp region-configuration
region-name test
instance 12 vlan 12
instance 34 vlan 34
active region-configuration

interface Vlanif12
ip address 192.168.12.4 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.12.254

interface Vlanif14
ip address 10.0.14.4 255.255.255.0

interface Vlanif34
ip address 192.168.34.4 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.34.254
vrrp vrid 2 priority 150

interface MEth0/0/1

interface GigabitEthernet0/0/1

interface GigabitEthernet0/0/2
port link-type access
port default vlan 14

interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 12 34

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 12 34

ip route-static 0.0.0.0 0.0.0.0 10.0.14.1

R1

interface GigabitEthernet0/0/0
ip address 10.0.12.1 255.255.255.0

interface GigabitEthernet0/0/1
ip address 10.0.13.1 255.255.255.0

interface GigabitEthernet0/0/2
ip address 10.0.14.1 255.255.255.0

interface LoopBack0
ip address 10.0.1.1 255.255.255.255

bgp 100
router-id 10.0.1.1
peer 10.0.2.2 as-number 100
peer 10.0.2.2 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
import-route static //导入静态,刚好静态通过ip route-static查看只有12、34段
peer 10.0.2.2 enable
peer 10.0.2.2 next-hop-local

ospf 1 router-id 10.0.1.1
area 0.0.0.0
network 10.0.1.1 0.0.0.0
network 10.0.12.1 0.0.0.0

ip route-static 192.168.12.0 255.255.255.0 10.0.13.3
ip route-static 192.168.12.0 255.255.255.0 10.0.14.4 preference 70
ip route-static 192.168.34.0 255.255.255.0 10.0.13.3 preference 70
ip route-static 192.168.34.0 255.255.255.0 10.0.14.4
//让12和34段的回去的包走原来出去的路径回包,源进源出

R2

isis 1
cost-style wide
network-entity 49.0001.0000.0000.0002.00
import-route ospf 1 level-1 //右边和r3建立的是级别1,这里导入ospf必须选择级别1

interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0

interface GigabitEthernet0/0/1
ip address 10.0.23.2 255.255.255.0
isis enable 1
isis circuit-level level-1 //只和右边r3建立的是级别1,所以不让这个口发级别2的包出

interface LoopBack0
ip address 10.0.2.2 255.255.255.255
isis enable 1

bgp 100
router-id 10.0.2.2
peer 10.0.1.1 as-number 100
peer 10.0.1.1 connect-interface LoopBack0
peer 10.0.3.3 as-number 100
peer 10.0.3.3 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
peer 10.0.1.1 enable
peer 10.0.1.1 reflect-client
peer 10.0.3.3 enable
peer 10.0.3.3 reflect-client

ospf 1 router-id 10.0.2.2
import-route isis 1
area 0.0.0.0
network 10.0.2.2 0.0.0.0
network 10.0.12.2 0.0.0.0

R3

dhcp enable

ip pool test
gateway-list 192.168.56.254
network 192.168.56.0 mask 255.255.255.0
excluded-ip-address 192.168.56.6
dns-list 192.168.1.1

isis 1
is-level level-1
cost-style wide
network-entity 49.0001.0000.0000.0003.00

firewall zone Local
priority 15

interface GigabitEthernet0/0/0

interface GigabitEthernet0/0/1
ip address 10.0.23.3 255.255.255.0
isis enable 1

interface GigabitEthernet0/0/2.35 //用子接口
dot1q termination vid 35
ip address 10.0.35.3 255.255.255.0
arp broadcast enable
dhcp select global

interface LoopBack0
ip address 10.0.3.3 255.255.255.255
isis enable 1

bgp 100
router-id 10.0.3.3
peer 10.0.2.2 as-number 100
peer 10.0.2.2 connect-interface LoopBack0

ipv4-family unicast
undo synchronization
import-route static //导入静态,刚好静态通过ip route-static查看只有56段
peer 10.0.2.2 enable
peer 10.0.2.2 next-hop-local

ip route-static 192.168.56.0 255.255.255.0 10.0.35.5

SW5

vlan batch 35 56

dhcp enable

interface Vlanif35
ip address 10.0.35.5 255.255.255.0

interface Vlanif56
ip address 192.168.56.254 255.255.255.0
dhcp select relay //中继R3上面的dhcp地址池
dhcp relay server-ip 10.0.35.3

interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 35

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 56

ip route-static 0.0.0.0 0.0.0.0 10.0.35.3

SW6

vlan batch 56

interface GigabitEthernet0/0/4
port link-type trunk
port trunk allow-pass vlan 56

interface GigabitEthernet0/0/10
port link-type access
port default vlan 56

interface GigabitEthernet0/0/11
port link-type access
port default vlan 56

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.rhkb.cn/news/233048.html

如若内容造成侵权/违法违规/事实不符,请联系长河编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

求更新后的路由表

假定网络中的路由器B的路由表有如下的项目 (这三列分别表示“目的网络“距离”和“下一跳路由器”): 现在B收到从C发来的路由信息(这两列分别表示“目的网络”和“距离”): 试求出路由器B更新后的路由表(详细说明每一个步骤)。 (1)首先把收到的路由信息的"距离"1: …

[论文阅读] Revisiting Feature Propagation and Aggregation in Polyp Segmentation

[论文地址] [代码] [MICCAI 23] Abstract 息肉的准确分割是筛查过程中有效诊断结直肠癌的关键步骤。 由于能够有效捕获多尺度上下文信息,普遍采用类似UNet 的编码器-解码器框架。 然而,两个主要限制阻碍了网络实现有效的特征传播和聚合。 首先&#xff…

我的创作纪念日——redis的历史纪录

机缘 最开始只想存留点Redis的操作信息,后来写着写着也就写多了,虽然后面很长时间由于忙就没继续写,但是还是偶尔登录看一下,有好几篇文章的浏览量还是很多的呢。 收获 收获不多,粉丝也才三十多个,浏览量感…

Nacos 持久化及集群的搭建【微服务】

文章目录 一、统一配置管理二、微服务配置拉取三、配置热更新四、多环境共享配置五、Nacos 集群搭建1. 集群结构2. 初始化数据库3. 搭建集群 六、Nginx 反向代理七、启动项目测试 一、统一配置管理 案例练习的时候我们只有两个微服务,管理起来非常简单,但…

【100个Cocos实例】通过重写源码实现循环PageView

引言 Cocos中通过重写源码实现循环PageView 大家好,有小伙伴私信我: 有没有办法实现循环的PageView列表的方法呢 本文将介绍一下Cocos中通过重写源码实现循环PageView。 本文源工程可在文末阅读原文获取,小伙伴们自行前往。 1.什么是Page…

【Spring实战】25 Spring Boot Admin 应用

文章目录 1. 查看健康信息2. 使用 Micrometer 和 "/metrics"3. 管理包和类的日志级别4. 其他功能总结 Spring Boot Admin 是一个功能强大的工具,用于监控和管理多个 Spring Boot 应用程序。通过上一篇文章 【Spring实战】24 使用 Spring Boot Admin 管理…

景联文科技GPT教育题库:AI教育大模型的强大数据引擎

GPT-4发布后,美国奥数队总教练、卡耐基梅隆大学数学系教授罗博认为,这个几乎是用“刷题”方式喂大的AI教育大模型的到来,意味着人类的刷题时代即将退出历史舞台。 未来教育将更加注重学生的个性化需求和多元化发展,借助GPT和AI教育…

工厂方法模式(Factory Method)

文章目录 定义与类型适用场景优点缺点工厂方法代码示例 定义与类型 定义:定义一个创建对象的接口,但让实现这个接口的类来决定实例化哪个类。工厂方法让类的实例化推迟到子类中进行。 类型:创建型。 适用场景 创建对象需要大量重复的代码…

mysql视图和sql语句

mysql视图和sql语句 一.mysql视图1.数据的虚拟表示:2.简化复杂查询:3.安全性和权限控制:4.逻辑数据组织:5.更新限制:6.视图的创建: 二.mysq语句使用案列 MySQL的视图(View)是一个虚拟…

如何向嵌入式设备中添加tcpdump工具

说明:tcpdump是一个在网络设备调试中一个非常重要的工具,它并不像hexdump等工具集成在busybox里面,也不像其他的软件一样只需要依赖linux标准的库就可以实现,它需要pcap相关的库和加密的相关库。 本文主要是基于realtek 83系列的…

[VUE]5-TypeScript

目录 1 TypeScript 介绍2、安装3、快速上手4、TypeScript 常用类型4.1 类型标注的位置4.2 字符串、数字、布尔类型4.3 字面量类型4.4 ⭐interface 类型4.5 class 类型 ​🍃作者介绍:双非本科大三网络工程专业在读,阿里云专家博主,…

三、Qt核心与Qt类库

一、Qt核心:元对象系统 1、Qt核心特点 Qt对标准C进行了扩展,引入了一些新的概念和功能元对象编译器(MOC)是一个预处理器,先将Qt的特性程序转为标准C程序,再由标准C编译器进行编译Qt为C语言增加的特性在Qt…

LeetCode第32题 : 最长有效括号

题目介绍 给你一个只包含 ( 和 ) 的字符串,找出最长有效(格式正确且连续)括号子串的长度。 示例 1: 输入:s "(()" 输出:2 解释:最长有效括号子串是 "()" 示例 2&#xf…

【Python机器学习】线性模型——用于多分类的线性模型

很多线性分类模型只使用与二分类问题,将二分类算法推广到多分类算法的一种常见方法是“一对其余”方法。在“一对其余”方法中,对每个类别都学习一个二分类模型,将这个类别和其他类别尽量区分,这样就生成了与类别数相同的二分类模…

设计模式——最全梳理,最好理解

新年献礼! 设计模式呕心梳理 创建型模式 单例模式(Singleton Pattern)https://blog.csdn.net/qq_34869143/article/details/134874044 整理中... 结构型模式 代理模式(Proxy Pattern)https://blog.csdn.net/qq_34…

Elasticsearch:Serarch tutorial - 使用 Python 进行搜索 (二)

这个是继上一篇文章 “Elasticsearch:Serarch tutorial - 使用 Python 进行搜索 (一)” 的续篇。在今天的文章中,我们接着来完成如何进行分页及过滤。 分页 - pagination 应用程序处理大量结果通常是不切实际的。 因此&#xff0…

css3 transform:scale

transform:scale 语法&#xff1a;transform:scale(x,y); <html> <head><style>.box1 {display: inline-block;width: 200px;height: 200px;background-color: pink;}.box2 {display: inline-block;width: 200px;height: 200px;background-color: red;tran…

电脑丢失dll文件怎么办,dll修复工具可一键修复dll问题

在计算机使用过程中&#xff0c;我们经常会遇到一些错误提示&#xff0c;其中最常见的就是“找不到指定的模块”或“无法找到某某.dll文件”。这种情况通常是由于dll文件丢失或损坏导致的。那么&#xff0c;究竟是什么原因导致了dll文件的丢失呢&#xff1f;又该如何预防dll文件…

Linux vi/vim 教程

文章目录 【 1. vi/vim 的三种模式 】1.1 命令模式1.2 输入模式1.3 底线命令模式 【 2. 实例 】【 3. vim 的其他命令 】 所有的 Unix Like 系统都会内建 vi 文本编辑器&#xff0c;其他的文本编辑器则不一定会存在。目前我们使用比较多的是 vim 编辑器。vim 从 vi 发展出来&am…

transforms的操作

一、transforms的操作 1、transforms.RandomChoice transforms.RandomChoice 是一个数据转换操作&#xff0c;用于从一系列的转换方法中随机选择一个进行数据增强。 参数&#xff1a; transforms&#xff1a;一个包含多个转换方法的列表或元组。 示例&#xff1a; import …