实验拓扑:
实验目的:
1.R5为ISP,只能进行IP地址配置,其所有地址均配为公有IP地址
2.R1和R5间使用PPP的PAP认证,R5为主认证方;R2与R5之间使用ppp的CHAP认证,R5为主认证方;R3与R5之间使用HDLC封装;
3.R1、R2、R3构建一个MGRE环境,R1为中心站点,R1、R4间为点到点的GRE;
4.整个私有网络基于RIP全网可达
5.所有PC设置私有IP为源IP,可以访问R5环回,达到全网通。
实验内容:
ip配置:
#R1配置
<R1>sys
Enter system view, return user view with Ctrl+Z.
[R1]int g0/0/0
[R1-GigabitEthernet0/0/0]ip add 192.168.1.254 24
[R1-GigabitEthernet0/0/0]int se4/0/0
[R1-Serial4/0/0]ip add 15.1.1.1 24#R2配置
[R2]int g0/0/0
[R2-GigabitEthernet0/0/0]ip add
[R2-GigabitEthernet0/0/0]ip address 192.168.2.254 24
[R2-GigabitEthernet0/0/0]int se4/0/0
[R2-Serial4/0/0]ip add 25.1.1.2 24#R3配置
[R3]int g0/0/0
[R3-GigabitEthernet0/0/0]ip add 192.168.3.254 24
[R3-GigabitEthernet0/0/0]int se4/0/0
[R3-Serial4/0/0]ip add 35.1.1.3 24#R4配置
[R4]int g0/0/1
[R4-GigabitEthernet0/0/1]ip add 192.168.4.254 24
[R4-GigabitEthernet0/0/1]int g0/0/0
[R4-GigabitEthernet0/0/0]ip add 45.1.1.4 24#R5配置
[ISP]int g0/0/0
[ISP-GigabitEthernet0/0/0]ip add 45.1.1.5 24
[ISP-GigabitEthernet0/0/0]int se4/0/1
[ISP-Serial4/0/1]ip add 15.1.1.5 24
[ISP-Serial4/0/1]int se3/0/1
[ISP-Serial3/0/1]ip add 25.1.1.5 24
[ISP-Serial3/0/1]int se4/0/0
[ISP-Serial4/0/0]ip add 35.1.1.5 24
[ISP-Serial4/0/0]q
[ISP]int LoopBack 0
[ISP-LoopBack0]ip add 5.5.5.5 24#配置静态缺省路由使公网通
[R1]ip route-static 0.0.0.0 0 15.1.1.5
[R2]ip route-static 0.0.0.0 0 25.1.1.5
[R3]ip route-static 0.0.0.0 0 35.1.1.5
[R4]ip route-static 0.0.0.0 0 45.1.1.5
测试公网通:
ppp验证配置:
R1与R5之间使用pap配置(R5为主认证方):
#R1配置
[R1]int se4/0/0
[R1-Serial4/0/0]ppp pap local-user wangdaye password cipher wdy123
[R1-Serial4/0/0]q#R5配置
[ISP]aaa
[ISP-aaa]local-user wangdaye password cipher wdy123
Info: Add a new user.
[ISP-aaa]local-user wangdaye service-type ppp
[ISP-aaa]q
[ISP]int se4/0/1
[ISP-Serial4/0/1]ppp authentication-mode pap
R1与R5之间使用chap配置(R5为主认证方):
#R2配置
[R2]int se4/0/0
[R2-Serial4/0/0]ppp chap user zhangdaye
[R2-Serial4/0/0]ppp chap password cipher zdy123#R5配置
[ISP]aaa
[ISP-aaa]local-user zhangdaye password cipher zdy123
Info: Add a new user.
[ISP-aaa]local-user zhangdaye service-type ppp
[ISP-aaa]int se3/0/1
[ISP-Serial3/0/1]ppp authentication-mode chap
R3与R5之间使用HDLC封装:
#R5
[ISP]int se4/0/0
[ISP-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y#R3
[R3]int se4/0/0
[R3-Serial4/0/0]link-protocol hdlc
Warning: The encapsulation protocol of the link will be changed. Continue? [Y/N]
:y
R1、R2、R3构建一个MGRE环境,R1为中心站点:
#R1配置
[R1]int Tunnel 0/0/0
[R1-Tunnel0/0/0]ip add 10.1.2.1 24
[R1-Tunnel0/0/0]tu
[R1-Tunnel0/0/0]tunnel-protocol g
[R1-Tunnel0/0/0]tunnel-protocol gre p2
[R1-Tunnel0/0/0]tunnel-protocol gre p2mp
[R1-Tunnel0/0/0]sou
[R1-Tunnel0/0/0]source 15.1.1.1
Mar 31 2024 11:26:15-08:00 R1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP
on the interface Tunnel0/0/0 has entered the UP state.
[R1-Tunnel0/0/0]
[R1-Tunnel0/0/0]nh
[R1-Tunnel0/0/0]nhrp ne
[R1-Tunnel0/0/0]nhrp network-id 100#R2配置
[R2]int Tunnel 0/0/0
[R2-Tunnel0/0/0]ip add 10.1.2.2 24
[R2-Tunnel0/0/0]tunnel-protocol gre p2mp
[R2-Tunnel0/0/0]source Serial 4/0/0
[R2-Tunnel0/0/0]nhrp network-id 100#R3配置
[R3]int Tunnel 0/0/0
[R3-Tunnel0/0/0]ip add 10.1.2.3 24
[R3-Tunnel0/0/0]tunnel-protocol gre p2mp
[R3-Tunnel0/0/0]source Serial 4/0/0
[R3-Tunnel0/0/0]nhrp network-id 100nhrp伪广播:
[R1-Tunnel0/0/0]nhrp entry multicast dynamic #注册从分支到中心站点
[R2-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register
[R3-Tunnel0/0/0]nhrp entry 10.1.2.1 15.1.1.1 register
nhrp伪广播:
[R1-Tunnel0/0/0]nhrp entry multicast dynamic
R1、R4间为点到点的GRE:
#R1配置
[R1]int t0/0/1
[R1-Tunnel0/0/1]ip add 10.1.1.1 24
[R1-Tunnel0/0/1]tunnel-protocol gre
[R1-Tunnel0/0/1]source 15.1.1.1
[R1-Tunnel0/0/1]destination 45.1.1.4
[R1-Tunnel0/0/1]q#R4配置
[R4]int t0/0/1
[R4-Tunnel0/0/1]ip add 10.1.1.4 24
[R4-Tunnel0/0/1]tunnel-protocol gre
[R4-Tunnel0/0/1]source 45.1.1.4
[R4-Tunnel0/0/1]destination 15.1.1.1
RIP v2配置
#R1配置
[R1]rip 1
[R1-rip-1]v 2
[R1-rip-1]undo summary
[R1-rip-1]network 192.168.1.0
[R1-rip-1]network 10.0.0.0#R2配置
[R2]rip 1
[R2-rip-1]undo summary
[R2-rip-1]v 2
[R2-rip-1]network 192.168.2.0
[R2-rip-1]network 10.0.0.0#R3配置
[R3]rip 1
[R3-rip-1]v 2
[R3-rip-1]undo summary
[R3-rip-1]network 192.168.3.0
[R3-rip-1]network 10.0.0.0#R4配置
[R4]rip 1
[R4-rip-1]v 2
[R4-rip-1]undo summary
[R4-rip-1]network 192.168.4.0
[R4-rip-1]network 10.0.0.0#关闭rip水平切割
[R1]undo rip split-horizon
[R2]undo rip split-horizon
[R3]undo rip split-horizon
所有PC设置私有IP为源IP,可以访问R5环回,达到全网通
#配置easy IP
#R1配置
[R1]acl 2000
[R1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[R1-acl-basic-2000]q
[R1]int se4/0/0
[R1-Serial4/0/0]nat outbound 2000#R2配置
[R2]acl 2000
[R2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[R2-acl-basic-2000]q
[R2]nat o
[R2]int se4/0/0
[R2-Serial4/0/0]nat outbound 2000#R3配置
[R3]acl 2000
[R3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[R3-acl-basic-2000]q
[R3]int se4/0/0
[R3-Serial4/0/0]nat outbound 2000#R4配置
[R4]acl 2000
[R4-acl-basic-2000]ru
[R4-acl-basic-2000]rule permit source 192.168.4.0 0.0.0.255
[R4-acl-basic-2000]q
[R4]int g0/0/0
[R4-GigabitEthernet0/0/0]nat outbound 2000