- 项目拓扑与项目需求
项目需求:某政务网络拥有两个园区,园区A和园区B之间通过物理专线相连。IP地址如图所示。现在需要实现以下需求:
- 要求A园区无法访问B园区的vlan 30 网络,要求使用路由过滤的方式实现。
- 配置步骤
- 设备IP地址的规划
设备名称 | 接口编号 | IP地址 |
LSW1 | Vlanif 1 | 10.0.11.10/24 |
Vlanif 10 | 10.1.1.254/24 | |
Vlanif 20 | 20.1.1.254/24 | |
AR1 | G0/0/0 | 10.0.12.1/24 |
G0/0/1 | 10.0.11.1/24 | |
AR2 | G0/0/0 | 10.0.12.2/24 |
G0/0/1 | 10.0.22.2/24 | |
LSW2 | Vlanif 1 | 10.0.22.20/24 |
Vlanif 30 | 30.1.1.254/24 | |
Vlanif 40 | 40.1.1.254/24 |
- 交换机VLANIF接口IP地址的配置
LSW1的配置
[LSW1]vlan batch 10 20
[LSW1]interface g0/0/2
[LSW1-GigabitEthernet0/0/2]port link-type access
[LSW1-GigabitEthernet0/0/2]port default vlan 10
[LSW1-GigabitEthernet0/0/2]interface g0/0/3
[LSW1-GigabitEthernet0/0/3]port default vlan 20
[LSW1]interface Vlanif 1
[LSW1-Vlanif1]ip address 10.1.11.10 24
[LSW1-Vlanif1]quit
[LSW1]interface Vlanif 10
[LSW1-Vlanif10]ip address 10.1.1.254 24
[LSW1-Vlanif10]quit
[LSW1]interface Vlanif 20
[LSW1-Vlanif20]ip address 20.1.1.254 24
[LSW1-Vlanif20]quit
LSW2的配置
[LSW2]vlan batch 30 40
[LSW2]interface g0/0/2
[LSW2-GigabitEthernet0/0/2]port link-type access
[LSW2-GigabitEthernet0/0/2]port default vlan 30
[LSW2-GigabitEthernet0/0/2]interface g0/0/3
[LSW2-GigabitEthernet0/0/3]port link-type access
[LSW2-GigabitEthernet0/0/3]port default vlan 40
[LSW2-GigabitEthernet0/0/3]quit
[LSW2]interface Vlanif 1
[LSW2-Vlanif1]ip address 10.0.22.20 24
[LSW2-Vlanif1]quit
[LSW2]interface Vlanif 30
[LSW2-Vlanif30]ip address 30.1.1.254 24
[LSW2-Vlanif30]quit
[LSW2]interface Vlanif 40
[LSW2-Vlanif40]ip address 40.1.1.254 24
[LSW2-Vlanif40]quit
- OSPF多进程的配置
LSW1的配置
[LSW1]ospf 200
[LSW1-ospf-200]area 0
[LSW1-ospf-200-area-0.0.0.0]network 10.1.1.0 0.0.0.255
[LSW1-ospf-200-area-0.0.0.0]network 20.1.1.0 0.0.0.255
[LSW1-ospf-200-area-0.0.0.0]network 10.0.11.0 0.0.0.255
[LSW1-ospf-200-area-0.0.0.0]quit
[LSW1-ospf-200]quit
LSW2的配置
[LSW2]ospf 300
[LSW2-ospf-300]area 0
[LSW2-ospf-300-area-0.0.0.0]network 10.0.22.0 0.0.0.255
[LSW2-ospf-300-area-0.0.0.0]network 30.1.1.0 0.0.0.255
[LSW2-ospf-300-area-0.0.0.0]network 40.1.1.0 0.0.0.255
[LSW2-ospf-300-area-0.0.0.0]quit
[LSW2-ospf-300]quit
AR1的配置
[AR1]ospf 200
[AR1-ospf-200]area 0
[AR1-ospf-200-area-0.0.0.0]network 10.0.11.0 0.0.0.255
[AR1-ospf-200-area-0.0.0.0]quit
[AR1-ospf-200]quit
[AR1]ospf 100
[AR1-ospf-100]area 0
[AR1-ospf-100-area-0.0.0.0]network 10.0.12.0 0.0.0.255
[AR1-ospf-100-area-0.0.0.0]quit
[AR1-ospf-100]quit
AR2的配置
[AR2]ospf 100
[AR2-ospf-100]area 0
[AR2-ospf-100-area-0.0.0.0]network 10.0.12.0 0.0.0.255
[AR2-ospf-100-area-0.0.0.0]quit
[AR2-ospf-100]quit
[AR2]ospf 300
[AR2-ospf-300]area 0
[AR2-ospf-300-area-0.0.0.0]network 10.0.22.0 0.0.0.255
[AR2-ospf-300-area-0.0.0.0]quit
[AR2-ospf-300]quit
- 路由引入
AR1的配置
[AR1]ospf 200
[AR1-ospf-200]import-route ospf 100
[AR1-ospf-200]ospf 100
[AR1-ospf-100]import-route ospf 200
[AR1-ospf-100]quit
AR2的配置
[AR2]ospf 100
[AR2-ospf-100]import-route ospf 300
[AR2-ospf-100]ospf 300
[AR2-ospf-300]import-route ospf 100
[AR2-ospf-300]quit
- 在LSW1上查询路由表
<LSW1>display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 12 Routes : 12
Destination/Mask Proto Pre Cost Flags NextHop Interface
10.0.11.0/24 Direct 0 0 D 10.0.11.10 Vlanif1
10.0.11.10/32 Direct 0 0 D 127.0.0.1 Vlanif1
10.0.12.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
10.0.22.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
10.1.1.0/24 Direct 0 0 D 10.1.1.254 Vlanif10
10.1.1.254/32 Direct 0 0 D 127.0.0.1 Vlanif10
20.1.1.0/24 Direct 0 0 D 20.1.1.254 Vlanif20
20.1.1.254/32 Direct 0 0 D 127.0.0.1 Vlanif20
30.1.1.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
40.1.1.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
<LSW1>
- 路由策略的配置
AR1的配置
[AR1]ip ip-prefix vlan30 permit 30.1.1.0 24
[AR1]route-policy vlan30 deny node 10
[AR1-route-policy]if-match ip-prefix vlan30
[AR1-route-policy]quit
[AR1]route-policy vlan30 permit node 20
[AR1-route-policy]quit
[AR1]ospf 200
[AR1-ospf-200]import-route ospf 100 route-policy vlan30
[AR1-ospf-200]quit
- 再次在LSW1上查询路由表
<LSW1>display ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
Destinations : 11 Routes : 11
Destination/Mask Proto Pre Cost Flags NextHop Interface
10.0.11.0/24 Direct 0 0 D 10.0.11.10 Vlanif1
10.0.11.10/32 Direct 0 0 D 127.0.0.1 Vlanif1
10.0.12.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
10.0.22.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
10.1.1.0/24 Direct 0 0 D 10.1.1.254 Vlanif10
10.1.1.254/32 Direct 0 0 D 127.0.0.1 Vlanif10
20.1.1.0/24 Direct 0 0 D 20.1.1.254 Vlanif20
20.1.1.254/32 Direct 0 0 D 127.0.0.1 Vlanif20
40.1.1.0/24 O_ASE 150 1 D 10.0.11.1 Vlanif1
127.0.0.0/8 Direct 0 0 D 127.0.0.1 InLoopBack0
127.0.0.1/32 Direct 0 0 D 127.0.0.1 InLoopBack0
<LSW1>
可以发现30.1.1.0的路由已经被过滤了
想要更多网工专业学习资料,可直接找我领取。(文末领取)
网工学习资源包领取 视频课程(部分示意) 实验拓扑(部分示意) |
如果需要系统深入的学习网工知识
↓ 可点赞+关注后通过下列方式领取资料↓
(没有领取门槛,主要是一个个发邮件太麻烦了)